Home     |     Forum     |     Guestbook Thursday, 02. October 2014
Home and News
Links and Affiliates
PHP-Scripts
Programs
Wallpapers
Miscellaneous
FAQ
Tips & Tricks
Links
Downloads
Contact
Imprint
Forum
Guestbook
# ICQ-Special » Downloads » Setups » ICQ Lite
ICQ Lite

For many users the standard and Pro version were to complex which resulted in the Lite version. Furthermore reaching a younger generation was desired. But aside from a bit more overwiev and all in all less configuration abilities there was nothing new at all. ICQ was available in several languages the first time ever.

Most versions only can be executed with ICQ Update Patch.

Order: descending | ascending
Download: ICQ Lite Beta Build #1066  
Release Date: 24.09.2002
Language: Size:  1.69 MB
Download: ICQ Lite Beta Build #1067  
Release Date: 05.11.2002
Language: Size:  1.69 MB
Download: ICQ Lite Beta Build #1068  
Release Date: 12.11.2002
Language: Size:  1.69 MB
Download: ICQ Lite Beta Build #1085 Korean  
Release Date: 16.01.2003
Language: Korean Size:  1.85 MB
Download: ICQ Lite Beta Build #1150  
Release Date: 20.02.2003
Language: Size:  1.95 MB
Download: ICQ Lite Alpha Build #1211  
Release Date: 03.06.2003
Language: Size:  1.78 MB
Download: ICQ Lite Build #1253  
Release Date: 02.07.2003
Language: Size:  1.80 MB
Download: ICQ Lite Build #1300  
Release Date: 29.09.2003
Language: Size:  1.81 MB
Download: ICQ Lite Build #1323 Danish  
Release Date: 24.11.2003
Language: Danish Size:  1.79 MB
Download: ICQ Lite Build #1324 Dutch  
Release Date: 26.11.2003
Language: Dutch Size:  1.79 MB
[1] [2]
Last Update: 08.08.2013
User:
Password:
 
- Advertisement -
- Recommendation -
Unser Tipp:Eigene ICQ Skins!schnell & einfach erstellen
- Partners -
icq-tools.de
message.DJ
fuehrerscheintest-online.de
Follow us on  
Contact     |     Imprint Code and Design by murb.com - All rights reserved 2002 - 2014
Visitors:  Online: 4  |  Online record: 344  |  Today: 355  |  Yesterday: 481  |  Day record: 24450  |  Total: 5366627
Website optimized for 1024x768 Pixel or higher and Firefox.